Twizy 3 Beeps

So I used my Twizy earlier to my essential travel for the day, came back, left it for a couple of hours, thought I better move it to charge it, 3 beeps, SERV, STOP and the 2 battery icons. OVMS showed more errors that I hoped:

DTC update (10 stored, 6 present):
NEW #01: 4/12 rev0 PRESENT(1x) G1 INT MEM Ef
   @ 9388km 0kph SOC=47% BV=14V TC=0 IC=18
NEW #02: 4/53 rev0 G1 INT MEM Ef
   @ 9388km 0kph SOC=47% BV=14V TC=0 IC=18
NEW #03: 4/75 rev0 PRESENT(1x) G2 MEM Ef
   @ 9388km 0kph SOC=47% BV=14V TC=0 IC=18
NEW #04: 4/14 rev0 PRESENT(1x) G2 INT MEM Ef
   @ 9388km 0kph SOC=47% BV=14V TC=0 IC=18
NEW #05: 4/17 rev0 PRESENT(1x) G2 INT MEM Ef
   @ 9388km 0kph SOC=47% BV=14V TC=0 IC=18
NEW #06: 4/11 rev0 G1 INT MEM Ef
   @ 9388km 0kph SOC=47% BV=14V TC=0 IC=18
NEW #07: 4/9 rev0 PRESENT(1x) G1 INT MEM Ef
   @ 9388km 0kph SOC=47% BV=14V TC=0 IC=18
NEW #08: 4/8 rev0 G1 INT MEM Ef
   @ 9388km 0kph SOC=47% BV=14V TC=0 IC=18
NEW #09: 4/63 rev0 INT MEM Ef
   @ 9388km 0kph SOC=47% BV=14V TC=0 IC=18
NEW #10: 4/62 rev0 PRESENT(1x) INT MEM Bt
   @ 9388km 0kph SOC=47% BV=14V TC=0 IC=18
DTC update (10 stored, 8 present):
UPD #09: 4/63 rev0 PRESENT(1x) INT MEM Ef
   @ 9388km 0kph SOC=47% BV=14V TC=0 IC=20
SEVCON Fault 0x45c3 [Warning]: Low Battery Cut
Info: Battery voltage (0x5100,1) is less than Under Voltage limit (0x2C02,2) for longer than the protection delay (0x2C03,0)
Action: Charge battery
SEVCON Fault 0x4dc3 [Severe]: Power Supply Critical
Info: Battery voltage has dropped below critical level
Action: Check controller voltage supply

Have pulled the 12v battery for a while and tried again, still the same issue. This looks like the SEVCON has gone nuts, any ideas?

Thanks

It gets better after trying another battery pull:

W (849274) v-twizy: SEVCON Fault 0x5442 [Return to Base]: Calibration Fault
……: Info: Calibration settings in controller are out of range
……: Action: Controller requires recalibration in production
W (849284) v-twizy: SEVCON Fault 0x5441 [Return to Base]: Incompatible hardware version
……: Info: Detected controller hardware version incompatible with software
……: Action: Check correct software is programmed into controller. Reprogram if necessary

RT-ENG-LogAlerts,0,86400,5442,|Return to Base|Calibration Fault|Calibration settings in controller are out of range|Controller requires recalibration in production
RT-ENG-LogAlerts,1,86400,54c4,|Return to Base|MOSFET s/c M1>B-|MOSFET s/c detection on M1 bottom devices|Check motor wiring. Check controller condition
RT-ENG-LogAlerts,2,86400,54c6,|Return to Base|MOSFET s/c M2>B-|MOSFET s/c detection on M2 bottom devices|Check motor wiring. Check controller condition
RT-ENG-LogAlerts,3,86400,54c8,|Return to Base|MOSFET s/c M3>B-|MOSFET s/c detection on M3 bottom devices|Check motor wiring. Check controller condition
RT-ENG-LogAlerts,4,86400,52c2,|Very Severe|DSP Overcurrent Fault|Motor current exceeded controller rated maximum|Check motor configuration and wiring
RT-ENG-LogAlerts,5,86400,4f41,|Severe|Internal Fault|Internal software fault|Internal software fault
RT-ENG-LogAlerts,6,86400,4dc3,|Severe|Power Supply Critical|Battery voltage has dropped below critical level|Check controller voltage supply
RT-ENG-LogAlerts,7,86400,4f01,|Severe|Unexpected slave state|CANopen slave has changed to unexpected state|Check status of all nodes on CANbus. 
RT-ENG-LogAlerts,8,86400,4581,|Warning|Throttle Fault (Warn)|Warning level throttle fault. Used for Renault Twizy|Check throttle wiring and installation.
RT-ENG-LogAlerts,9,86400,4602,|Warning|Device too hot|High heatsink temperature (0x5100;4) has reduced power to motor|Allow controller to cool down to normal operating temperature.

You are charging the 12V before re-inserting and is it holding a good charge?
Have you checked it when you removed it?

2 Likes

Yes, the battery is holding about 13v which I know is a little high. It’s a new one too.

Is this a Sevcon or instrument panel fault?


I’m having an instrument panel issue myself…and it looks something like this…

Some problem with the sevcon is activating the imobiliser circuit that the canclip translates in that manner…once the problem is solved returns automatically to normal…

hi
I’ve been reading your posts, I had the same problems turns out it was the Sevcon Unit I changed it for a OEM one which was a mistake as my Powerbox does’nt work any more
if you are changing it talk to Kenneth as he will sell you one with a Powerbox cheaper than the OEM one