Windshield nozzles (water jet?) not working

My Twizy’s windshield nozzle does not work. The windshield wipers do work fine, it is just that I cannot use the water nozzles to clean up the windshield.
I’ve checked the hose for a possible obstruction but there seems to be nothing wrong there. When I pull the lever on the dashboard, nothing happens, no electrical sound of any pump whatsoever.

Does anyone know how to solve this issue? Many thanks!

Check the fuses!

Then it’s a matter of tracing through and checking the power at the pump.

There is water in the bottle and no obvious obstructions at that end? Although the pump would still run.

The other thing that could fail is the switch, which is all part of the arm that fails for the heated front screen.

Hmm fuse is the same for washer and wiper and wiper works, so it’s not he fuse problem. If there’s no sound from the washer pump, it should be stucked with some debris or have no power. So check first with 12V voltage checker on pump contacts. If there is power, pump is stucked or it’s motor is dead…

It will need a new washer bottle

They are integrated with the pump.

I finally solved it. I must admit it has been a real PITA. I did check every single one of those fuses, just to discard them as the cause.

The access to the pump wires is hard. So I decided to remove the front of the Twizy to gain full access.

The thing is power was delivered trhu the wires to the pump. But the pump would no work.
I ordered a new pump on Oscaro: 7.78€ total with UPS shipping to a hardware store next to my house. Oscaro would not list that item as a Twizy part, but after searching many webs I did come to the conclusion that unit would work. It is SEIM - 109261

Here are both pumps. New one has the white stripe. Apart from that, it is identical to the original one:

1 Like

I installed it…but no luck…it would not work. Did I get the wrong pump? I used a small 12V battery I keep at hand and powered the pump. It did work.

I check with the volt meter again the wire connector to the pump. It did get electrical current. WTF?

I plugged 2 wires from the connector into the pump. It did work! So I guess the connector and the pump were not working when plugged together. After much fiddling with them I found out that when the wires coming to the pump were bent to one side, the pump would work just fine.

Since the bottle is tucked next to a plastic part of the front of the car, I could just place the wire in there and it would be trapped and in a fixed position.

.

Eventually I might need to change the connector, but so far it has worked ever since.

Just in case…Does anyone know where to get such waterproof connector?